Improper Limitation of a Pathname to a Restricted Directory in plexus-archiverGHSA-hcxq-x77q-3469
MEDIUMFix: codehaus-plexus/plexus-archiver#87GHSA-hcxq-x77q-3469 is a medium-severity (CVSS 5.5) Path Traversal vulnerability in org.codehaus.plexus:plexus-archiver. 4 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.codehaus.plexus:plexus-archiver — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.codehaus.plexus:plexus-archiverReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
plexus-archiver before 3.6.0 is vulnerable to directory traversal, allowing attackers to write to arbitrary files via a ../ (dot dot slash) in an archive entry that is mishandled during extraction. This vulnerability is also known as 'Zip-Slip'.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.codehaus.plexus:plexus-archiver | all versions | 3.6.0org.codehaus.plexus:plexus-archiver:3.6.0 |
Affected Products
plexus-archivercodehaus-plexusdebian linuxdebianenterprise linuxredhatenterprise linux desktopredhatenterprise linux workstationredhatResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.codehaus.plexus:plexus-archiver, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.codehaus.plexus:plexus-archiver to 3.6.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-hcxq-x77q-3469 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 7 | plexus-archiver-0:2.4.2-5.el7_5 | RHSA-2018:1836 |
| Red Hat Software Collections for Red Hat Enterprise Linux 6 | rh-maven33-plexus-archiver-0:2.4.2-5.1.el6 | RHSA-2018:1837 |
Frequently Asked Questions
Is GHSA-hcxq-x77q-3469 in your dependencies?
Find it across Maven, including transitive dependencies.