NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

Drupal core allows Content SpoofingGHSA-h89p-5896-f4q8

GHSA-h89p-5896-f4q8 is a CWE-451 vulnerability in drupal/core. A fix is available for drupal/core — see the affected versions and patch details below.

Also known asBIT-drupal-2025-13082CVE-2025-13082DRUPAL-CORE-2025-007
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-h89p-5896-f4q8.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs16th percentile — riskier than 16% of all scored CVEsHighest risk
0.00%0.25%0.50%0.74%0.0%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

4 pkgs affected
🐘drupal/core🐘drupal/core🐘drupal/core🐘drupal/core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

User Interface (UI) Misrepresentation of Critical Information vulnerability in Drupal Drupal core allows Content Spoofing. This issue affects Drupal core: from 8.0.0 before 10.4.9, from 10.5.0 before 10.5.6, from 11.0.0 before 11.1.9, from 11.2.0 before 11.2.8.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistdrupal/core≥ 8.0.0&&< 10.4.910.4.9composer require drupal/core:^10.4.9
🐘Packagistdrupal/core≥ 10.5.0&&< 10.5.610.5.6composer require drupal/core:^10.5.6
🐘Packagistdrupal/core≥ 11.0.0&&< 11.1.911.1.9composer require drupal/core:^11.1.9
🐘Packagistdrupal/core≥ 11.2.0&&< 11.2.811.2.8composer require drupal/core:^11.2.8

Affected Products

1 product · 4 configurations
Application
drupaldrupal
≥ 11.2.0 && < 11.2.8
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update drupal/core to 10.4.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-h89p-5896-f4q8 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

User Interface (UI) Misrepresentation of Critical Information vulnerability in Drupal Drupal core allows Content Spoofing. This issue affects Drupal core: from 8.0.0 before 10.4.9, from 10.5.0 before 10.5.6, from 11.0.0 before 11.1.9, from 11.2.0 before 11.2.8.
O3 Security · Impact-Aware SCA

Is GHSA-h89p-5896-f4q8 in your dependencies?

Find it across Packagist, including transitive dependencies.

Drupal core allows Content Spoofing