Use of Externally-Controlled Input to Select Classes or Code in InfinispanGHSA-h47x-2j37-fw5m
HIGHFix: infinispan/infinispan@5dbb05cGHSA-h47x-2j37-fw5m is a high-severity (CVSS 7.5) CWE-470 vulnerability in org.infinispan:infinispan-core. A fix is available for org.infinispan:infinispan-core — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.infinispan:infinispan-core☕org.infinispan:infinispan-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
A vulnerability was found in Infinispan such that the invokeAccessibly method from the public class ReflectionUtil allows any application class to invoke private methods in any class with Infinispan's privileges. The attacker can use reflection to introduce new, malicious behavior into the application.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.infinispan:infinispan-core | all versions | 8.2.12.Finalorg.infinispan:infinispan-core:8.2.12.Final |
| ☕Maven | org.infinispan:infinispan-core | ≥ 9.0.0.Final&&< 9.4.17.Final | 9.4.17.Finalorg.infinispan:infinispan-core:9.4.17.Final |
Affected Products
infinispaninfinispanactive iq unified managernetappfuseredhatjboss data gridredhatjboss enterprise application platformredhatopenshift application runtimesredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.infinispan:infinispan-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.infinispan:infinispan-core to 8.2.12.Final or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-h47x-2j37-fw5m is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Red Hat OpenStack Platform's OpenDaylight contains the vulnerable library. This library is a requirement of other dependencies (Karaf and Hibernate). Under supported deployments, the vulnerable functionality is not utilized. Based on this, no OpenDaylight versions will not be fixed.
There is no known mitigation for this issue.Source: Red Hat security advisory for GHSA-h47x-2j37-fw5m (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| EAP-CD 19 Tech Preview | infinispan-core | RHSA-2020:2333 |
| Red Hat Data Grid 7.3.3 | infinispan-core | RHSA-2020:0727 |
| Red Hat Fuse 6.3 | infinispan-core | RHSA-2020:0481 |
| Red Hat Fuse 7.6.0 | infinispan-core | RHSA-2020:0983 |
| Red Hat JBoss EAP 7.2 | infinispan-core | RHSA-2020:2062 |
| Red Hat JBoss Enterprise Application Platform 7.1 EUS for RHEL 7 | eap7-infinispan-0:8.2.11-1.SP2_redhat_00001.1.ep7.el7 | RHSA-2024:5856 |
| Red Hat JBoss Enterprise Application Platform 7.2 for RHEL 6 | eap7-glassfish-jsf-0:2.3.5-11.SP3_redhat_00009.1.el6eap | RHSA-2020:2063 |
| Red Hat Openshift Application Runtimes Vert.x 3.8.3 | infinispan-core | RHSA-2019:3901 |
Frequently Asked Questions
Is GHSA-h47x-2j37-fw5m in your dependencies?
Find it across Maven, including transitive dependencies.