CVE-2017-15089 is a high-severity (CVSS 8.8) Deserialization of Untrusted Data vulnerability in org.infinispan:infinispan-core. A fix is available for org.infinispan:infinispan-core — see the affected versions and patch details below.
Deserialization of Untrusted Data in Infinispan
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.infinispan:infinispan-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
It was found that the Hotrod client in Infinispan before 9.2.0.CR1 would unsafely read deserialized data on information from the cache. An authenticated attacker could inject a malicious object into the data cache and attain deserialization on the client, and possibly conduct further attacks.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.infinispan:infinispan-core | all versions | 9.2.0.CR1org.infinispan:infinispan-core:9.2.0.CR1 |
Affected Products
infinispaninfinispanDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.infinispan:infinispan-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.infinispan:infinispan-core to 9.2.0.CR1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-15089 is resolved across your whole dependency graph.
Workarounds
Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Data Grid 7.1.2 | infinispan-core | RHSA-2018:0294 |
| Red Hat Fuse 6.3 | camel | RHSA-2019:1326 |
| Red Hat JBoss EAP 7.1 | infinispan-core | RHSA-2018:0478 |
| Red Hat JBoss Enterprise Application Platform 7.1 for RHEL 6 | eap7-activemq-artemis-0:1.5.5.009-1.redhat_1.1.ep7.el6 | RHSA-2018:0479 |
| Red Hat JBoss Enterprise Application Platform 7.1 for RHEL 6 | eap7-jboss-ec2-eap-0:7.1.1-3.1.GA_redhat_3.ep7.el6 | RHSA-2018:0481 |
| Red Hat JBoss Enterprise Application Platform 7.1 for RHEL 7 | eap7-activemq-artemis-0:1.5.5.009-1.redhat_1.1.ep7.el7 | RHSA-2018:0480 |
| Red Hat JBoss Enterprise Application Platform Continuous Delivery | infinispan-core | RHSA-2020:2561 |
| Red Hat Single Sign-On 7.2.1 zip | see advisory | RHSA-2018:0501 |
Frequently Asked Questions
Is CVE-2017-15089 in your dependencies?
Find it across Maven, including transitive dependencies.