Possible ReDoS vulnerability in block_format in Action MailerGHSA-h47h-mwp9-c6q6
GHSA-h47h-mwp9-c6q6 is a CWE-1333 vulnerability in actionmailer. A fix is available for actionmailer — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-h47h-mwp9-c6q6.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
actionmailer💎actionmailer💎actionmailer💎actionmailerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
There is a possible ReDoS vulnerability in the block_format helper in Action Mailer. This vulnerability has been assigned the CVE identifier CVE-2024-47889.
Impact
Carefully crafted text can cause the block_format helper to take an unexpected amount of time, possibly resulting in a DoS vulnerability. All users running an affected release should either upgrade or apply the relevant patch immediately.
Ruby 3.2 has mitigations for this problem, so Rails applications using Ruby 3.2 or newer are unaffected. Rails 8.0.0.beta1 requires Ruby 3.2 or greater so is unaffected.
Releases
The fixed releases are available at the normal locations.
Workarounds
Users can avoid calling the block_format helper or upgrade to Ruby 3.2
Credits
Thanks to yuki_osaki for the report!
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | actionmailer | ≥ 3.0.0&&< 6.1.7.9 | 6.1.7.9bundle update actionmailer --conservative |
| 💎RubyGems | actionmailer | ≥ 7.0.0&&< 7.0.8.5 | 7.0.8.5bundle update actionmailer --conservative |
| 💎RubyGems | actionmailer | ≥ 7.1.0&&< 7.1.4.1 | 7.1.4.1bundle update actionmailer --conservative |
| 💎RubyGems | actionmailer | ≥ 7.2.0&&< 7.2.1.1 | 7.2.1.1bundle update actionmailer --conservative |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for actionmailer, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update actionmailer to 6.1.7.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-h47h-mwp9-c6q6 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Users can avoid calling the block_format helper or upgrade to Ruby 3.2.Source: Red Hat security advisory for GHSA-h47h-mwp9-c6q6 (CC BY 4.0)
Frequently Asked Questions
Is GHSA-h47h-mwp9-c6q6 in your dependencies?
Find it across RubyGems, including transitive dependencies.