CVE-2013-4389 — actionmailer
CVE-2013-4389 is a CWE-134 vulnerability in actionmailer. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for actionmailer — see the affected versions and patch details below.
actionmailer email address processing causes Denial of service
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
actionmailerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
Multiple format string vulnerabilities in log_subscriber.rb files in the log subscriber component in Action Mailer in Ruby on Rails 3.x before 3.2.15 allow remote attackers to cause a denial of service via a crafted e-mail address that is improperly handled during construction of a log message.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | actionmailer | ≥ 3.0.0&&< 3.2.15 | 3.2.15bundle update actionmailer --conservative |
Affected Products
debian linuxdebianopensuseopensuserailsrubyonrailsResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for actionmailer, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update actionmailer to 3.2.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-4389 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Red Hat Product Security has rated this issue as having Low security impact. This issue is not currently planned to be addressed in future updates. For additional information, refer to the Issue Severity Classification: https://access.redhat.com/security/updates/classification/. This issue did not affect the versions…
| Product | Fixed in | Advisory |
|---|---|---|
| CloudForms Management Engine 5.4 | cfme-0:5.4.0.5-1.el6cf | RHBA-2015:1100 |
Frequently Asked Questions
Is CVE-2013-4389 in your dependencies?
Find it across RubyGems, including transitive dependencies.