Ray OS Command Injection vulnerabilityGHSA-h3xg-wv58-5p43
CRITICALGHSA-h3xg-wv58-5p43 is a critical-severity (CVSS 9.8) OS Command Injection vulnerability in ray. 4 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for ray — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
rayReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
A command injection existed in Ray's cpu_profile URL parameter allowing attackers to execute os commands on the system running the ray dashboard remotely without authentication. The issue is fixed in version 2.8.1+. Ray maintainers' response can be found here: https://www.anyscale.com/blog/update-on-ray-cves-cve-2023-6019-cve-2023-6020-cve-2023-6021-cve-2023-48022-cve-2023-48023
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | ray | all versions | 2.8.1pip install --upgrade 'ray==2.8.1' |
Affected Products
rayray_projectResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Ray OS v2.6.3 - Command Injection RCE(Unauthorized)
by Fire_Wolf · Apr 12, 2024
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ray, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ray to 2.8.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-h3xg-wv58-5p43 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is GHSA-h3xg-wv58-5p43 in your dependencies?
Find it across PyPI, including transitive dependencies.