GHSA-gv98-g628-m9x5 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in django. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for django — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
django🐍django🐍djangoReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
The django.util.http.is_safe_url function in Django before 1.4.18, 1.6.x before 1.6.10, and 1.7.x before 1.7.3 does not properly handle leading whitespaces, which allows remote attackers to conduct cross-site scripting (XSS) attacks via a crafted URL, related to redirect URLs, as demonstrated by a \njavascript: URL.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | django | all versions | 1.4.18pip install --upgrade 'django==1.4.18' |
| 🐍PyPI | django | ≥ 1.6&&< 1.6.10 | 1.6.10pip install --upgrade 'django==1.6.10' |
| 🐍PyPI | django | ≥ 1.7&&< 1.7.3 | 1.7.3pip install --upgrade 'django==1.7.3' |
Affected Products
ubuntu linuxcanonicaldjangodjangoprojectResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for django, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update django to 1.4.18 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-gv98-g628-m9x5 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-gv98-g628-m9x5 in your dependencies?
Find it across PyPI, including transitive dependencies.