NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2015-0220 — django

MEDIUMFix: django/django@4c241f1

CVE-2015-0220 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in django. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for django — see the affected versions and patch details below.

Django Cross-site Scripting Vulnerability

Also known asGHSA-gv98-g628-m9x5PYSEC-2015-5
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs88th percentile — riskier than 88% of all scored CVEsHighest risk
1.65%2.29%2.92%3.55%2.5%3.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐍django🐍django🐍django

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

The django.util.http.is_safe_url function in Django before 1.4.18, 1.6.x before 1.6.10, and 1.7.x before 1.7.3 does not properly handle leading whitespaces, which allows remote attackers to conduct cross-site scripting (XSS) attacks via a crafted URL, related to redirect URLs, as demonstrated by a "\njavascript:" URL.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIdjangoall versions1.4.18pip install --upgrade 'django==1.4.18'
🐍PyPIdjango≥ 1.6&&< 1.6.101.6.10pip install --upgrade 'django==1.6.10'
🐍PyPIdjango≥ 1.7&&< 1.7.31.7.3pip install --upgrade 'django==1.7.3'

Affected Products

2 products · 18 configurations
OS
ubuntu linuxcanonical
4 versions
10.0412.0414.0414.10
Application
djangodjangoproject
≤ 1.4.17
13 versions
1.61.6.11.6.21.6.31.6.41.6.51.6.61.6.71.6.81.6.91.71.7.1
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for django, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update django to 1.4.18 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-0220 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

The django.util.http.is_safe_url function in Django before 1.4.18, 1.6.x before 1.6.10, and 1.7.x before 1.7.3 does not properly handle leading whitespaces, which allows remote attackers to conduct cross-site scripting (XSS) attacks via a crafted URL, related to redirect URLs, as demonstrated by a "\njavascript:" URL.
O3 Security · Impact-Aware SCA

Is CVE-2015-0220 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2015-0220: django XSS — Fixed in 1.4.18