Moodle Bypass email verification secret when confirming account registrationGHSA-grj4-g57c-9xmv
MEDIUMGHSA-grj4-g57c-9xmv is a medium-severity (CVSS 5.3) CWE-863 vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
When creating a user account, it was possible to verify the account without having access to the verification email link/secret in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | moodle/moodle | ≥ 3.5&&< 3.5.17 | 3.5.17composer require moodle/moodle:^3.5.17 |
| 🐘Packagist | moodle/moodle | ≥ 3.8&&< 3.8.8 | 3.8.8composer require moodle/moodle:^3.8.8 |
| 🐘Packagist | moodle/moodle | ≥ 3.9&&< 3.9.5 | 3.9.5composer require moodle/moodle:^3.9.5 |
| 🐘Packagist | moodle/moodle | ≥ 3.10&&< 3.10.2 | 3.10.2composer require moodle/moodle:^3.10.2 |
Affected Products
fedorafedoraprojectmoodlemoodleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update moodle/moodle to 3.5.17 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-grj4-g57c-9xmv is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is GHSA-grj4-g57c-9xmv in your dependencies?
Find it across Packagist, including transitive dependencies.