NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2021-20282 — moodle

MEDIUM

CVE-2021-20282 is a medium-severity (CVSS 5.3) CWE-863 vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

Moodle Bypass email verification secret when confirming account registration

Also known asBIT-moodle-2021-20282GHSA-grj4-g57c-9xmv
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs71th percentile — riskier than 71% of all scored CVEsHighest risk
0.00%0.61%1.21%1.82%0.2%1.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

When creating a user account, it was possible to verify the account without having access to the verification email link/secret in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodle≥ 3.5&&< 3.5.173.5.17composer require moodle/moodle:^3.5.17
🐘Packagistmoodle/moodle≥ 3.8&&< 3.8.83.8.8composer require moodle/moodle:^3.8.8
🐘Packagistmoodle/moodle≥ 3.9&&< 3.9.53.9.5composer require moodle/moodle:^3.9.5
🐘Packagistmoodle/moodle≥ 3.10&&< 3.10.23.10.2composer require moodle/moodle:^3.10.2

Affected Products

2 products · 6 configurations
OS
fedorafedoraproject
2 versions
3234
Application
moodlemoodle
≥ 3.10.0 && < 3.10.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moodle/moodle to 3.5.17 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-20282 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

When creating a user account, it was possible to verify the account without having access to the verification email link/secret in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.
O3 Security · Impact-Aware SCA

Is CVE-2021-20282 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2021-20282: moodle — Fixed in 3.5.17