NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
CRITICAL severity

wger vulnerable to brute force attemptsGHSA-gr58-76rp-mmg4

CRITICALFix: wger-project/wger@5e3167e

GHSA-gr58-76rp-mmg4 is a critical-severity (CVSS 9.8) CWE-307 vulnerability in wger. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for wger — see the affected versions and patch details below.

Also known asCVE-2022-2650PYSEC-2026-573
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
3 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for GHSA-gr58-76rp-mmg4.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs55th percentile — riskier than 55% of all scored CVEsHighest risk
0.00%0.41%0.83%1.24%0.2%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍wger

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Improper Restriction of Excessive Authentication Attempts in GitHub repository wger-project/wger prior to 2.2.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIwgerall versions2.2pip install --upgrade 'wger==2.2'

Affected Products

1 product · 1 configurations
Application
wgerwger
< 2.2
range
Exploits & PoCs
3

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for wger, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update wger to 2.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-gr58-76rp-mmg4 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Improper Restriction of Excessive Authentication Attempts in GitHub repository wger-project/wger prior to 2.2.
O3 Security · Impact-Aware SCA

Is GHSA-gr58-76rp-mmg4 in your dependencies?

Find it across PyPI, including transitive dependencies.

GHSA-gr58-76rp-mmg4: wger — Fixed in 2.2