NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

No Charset in Content-Type Header in expressGHSA-gpvr-g6gh-9mc2

MEDIUM

GHSA-gpvr-g6gh-9mc2 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in express. A fix is available for express — see the affected versions and patch details below.

Also known asCVE-2014-6393
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs67th percentile — riskier than 67% of all scored CVEsHighest risk
0.00%0.55%1.10%1.64%0.3%1.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

109Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
expressnpm
194.3Mdownloads / week

Description

Vulnerable versions of express do not specify a charset field in the content-type header while displaying 400 level response messages. The lack of enforcing user's browser to set correct charset, could be leveraged by an attacker to perform a cross-site scripting attack, using non-standard encodings, like UTF-7.

Recommendation

For express 3.x, update express to version 3.11 or later. For express 4.x, update express to version 4.5 or later.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
📦npmexpressall versions3.11.0npm install express@3.11.0
📦npmexpress≥ 4.0.0&&< 4.5.04.5.0npm install express@4.5.0

Affected Products

1 product · 15 configurations
Application
expressopenjsf
≤ 3.10.5
14 versions
4.0.04.1.04.1.14.1.24.2.04.3.04.3.14.3.24.4.04.4.14.4.24.4.3

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for express, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update express to 3.11.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-gpvr-g6gh-9mc2 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Vulnerable versions of express do not specify a charset field in the content-type header while displaying 400 level response messages. The lack of enforcing user's browser to set correct charset, could be leveraged by an attacker to perform a cross-site scripting attack, using non-standard encodings, like UTF-7. ## Recommendation For express 3.x, update express to version 3.11 or later. For express 4.x, update express to version 4.5 or later.
O3 Security · Impact-Aware SCA

Is GHSA-gpvr-g6gh-9mc2 in your dependencies?

Find it across npm, including transitive dependencies.

No Charset in Content-Type Header in express