Path Traversal in TYPO3 CoreGHSA-gj48-w74w-8gvm
GHSA-gj48-w74w-8gvm is a security vulnerability in typo3/cms. A fix is available for typo3/cms — see the affected versions and patch details below.
Real-World Exposure
typo3/cms🐘typo3/cms🐘typo3/cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Due to a too loose type check in an API method, attackers could bypass the directory traversal check by providing an invalid UTF-8 encoding sequence.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/cms | ≥ 6.2.0&&< 6.2.29 | 6.2.29composer require typo3/cms:^6.2.29 |
| 🐘Packagist | typo3/cms | ≥ 7.6.0&&< 7.6.13 | 7.6.13composer require typo3/cms:^7.6.13 |
| 🐘Packagist | typo3/cms | ≥ 8.0.0&&< 8.4.1 | 8.4.1composer require typo3/cms:^8.4.1 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/cms to 6.2.29 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-gj48-w74w-8gvm is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Frequently Asked Questions
Is GHSA-gj48-w74w-8gvm in your dependencies?
Find it across Packagist, including transitive dependencies.