NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

Typo3 Security Misconfiguration in User Session HandlingGHSA-g9rv-6g56-65h8

GHSA-g9rv-6g56-65h8 is a security vulnerability in typo3/cms. A fix is available for typo3/cms — see the affected versions and patch details below.

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Dec 2, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

2 pkgs affected
🐘typo3/cms🐘typo3/cms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

When users change their password existing sessions for that particular user account are not revoked. A valid backend or frontend user account is required in order to make use of this vulnerability.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagisttypo3/cms≥ 8.0.0&&< 8.7.258.7.25composer require typo3/cms:^8.7.25
🐘Packagisttypo3/cms≥ 9.0.0&&< 9.5.69.5.6composer require typo3/cms:^9.5.6

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update typo3/cms to 8.7.25 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-g9rv-6g56-65h8 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

When users change their password existing sessions for that particular user account are not revoked. A valid backend or frontend user account is required in order to make use of this vulnerability.
O3 Security · Impact-Aware SCA

Is GHSA-g9rv-6g56-65h8 in your dependencies?

Find it across Packagist, including transitive dependencies.

Typo3 Security Misconfiguration in User Session Handling