NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

CWA-2024-005: Stackoverflow in wasmdGHSA-g8w7-7vgg-x7xg

HIGHFix: CosmWasm/wasmd@71cf6a8

GHSA-g8w7-7vgg-x7xg is a high-severity (CVSS 7.5) vulnerability in github.com/CosmWasm/wasmd. A fix is available for github.com/CosmWasm/wasmd — see the affected versions and patch details below.

Also known asGO-2024-3082
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Aug 30, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

2 pkgs affected
🐹github.com/CosmWasm/wasmd🐹github.com/CosmWasm/wasmd

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Component: wasmd Criticality: High (ACMv1: I:Critical; L:Likely) Patched versions: wasmd 0.53.0, 0.46.0

See CWA-2024-005 for more details.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/CosmWasm/wasmd≥ 0.50.0&&< 0.53.00.53.0go get github.com/CosmWasm/wasmd@v0.53.0
🐹Gogithub.com/CosmWasm/wasmdall versions0.46.0go get github.com/CosmWasm/wasmd@v0.46.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/CosmWasm/wasmd, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/CosmWasm/wasmd to 0.53.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-g8w7-7vgg-x7xg is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

**Component:** wasmd **Criticality:** High ([ACMv1](https://github.com/interchainio/security/blob/main/resources/CLASSIFICATION_MATRIX.md): I:Critical; L:Likely) **Patched versions:** wasmd 0.53.0, 0.46.0 See [CWA-2024-005](https://github.com/CosmWasm/advisories/blob/main/CWAs/CWA-2024-005.md) for more details.
O3 Security · Impact-Aware SCA

Is GHSA-g8w7-7vgg-x7xg in your dependencies?

Find it across Go, including transitive dependencies.

CWA-2024-005: Stackoverflow in wasmd (High 7.5)