NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹 Go
Not in CISA KEV

CWA-2025-006: wasmd's improper error handling may lead to IBC channel opening despite errorGHSA-79xg-q4qm-7v9w

GHSA-79xg-q4qm-7v9w is a security vulnerability in github.com/CosmWasm/wasmd. A fix is available for github.com/CosmWasm/wasmd — see the affected versions and patch details below.

Also known asGO-2025-3755
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Jun 12, 2025 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

4 pkgs affected
🐹github.com/CosmWasm/wasmd🐹github.com/CosmWasm/wasmd🐹github.com/CosmWasm/wasmd🐹github.com/CosmWasm/wasmd

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

CWA-2025-006: Improper error handling may lead to IBC channel opening despite error

Severity

High (Considerable + Likely)1

Affected versions:

  • wasmd 0.60.0
  • wasmd >= 0.51.0 < 0.55.1

Patched versions:

  • wasmd 0.60.1, 0.55.1, 0.54.1, 0.53.3

Description of the bug

A contract erroring during IBC channel opening does not prevent the channel from opening.

Applying the patch

The patch will be shipped in a wasmd release. You will also have to update libwasmvm if you build statically. If you already use the latest / close to latest wasmd, you can update more or less as follows:

  1. Check the current wasmd version: go list -m github.com/CosmWasm/wasmd
  2. Bump the github.com/CosmWasm/wasmd dependency in your go.mod to 0.60.1 (Cosmos SDK 0.53 compatible), 0.55.1 (Cosmos SDK 0.50 compatible), 0.54.1 or 0.53.3; go mod tidy; commit.
  3. If you use the static libraries libwasmvm_muslc.aarch64.a/libwasmvm_muslc.x86_64.a, make sure that you use the same version as your wasmvm version.
  4. Check the updated wasmd version: go list -m github.com/CosmWasm/wasmd and ensure you see 0.60.1, 0.55.1, 0.54.1 or 0.53.3.
  5. Follow your regular practices to deploy chain upgrades.

The patch is consensus breaking.

Acknowledgement

This problem was discovered during an audit of the CosmWasm stack performed by Sherlock and funded by ICF/ICL in Q1 2025. Thank you for that work!

If you believe you have found a bug in the Interchain Stack or would like to contribute to the program by reporting a bug, please see https://hackerone.com/cosmos.

Timeline

  • 2025-03-03: Auditor informs Confio about this issue.
  • 2025-04-10: Confio developed the patch internally.
  • 2025-06-05: Upcoming patch is announced.
  • 2025-06-10: Patch is released.

Footnotes

  1. following Amulet's Severity Classification Framework ACMv1.2: https://github.com/interchainio/security/blob/0295254e8645301ccb606d46108a45cede0a73e0/resources/CLASSIFICATION_MATRIX.md ↩

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/CosmWasm/wasmd≥ 0.60.0&&< 0.60.10.60.1go get github.com/CosmWasm/wasmd@v0.60.1
🐹Gogithub.com/CosmWasm/wasmd≥ 0.55.0&&< 0.55.10.55.1go get github.com/CosmWasm/wasmd@v0.55.1
🐹Gogithub.com/CosmWasm/wasmd≥ 0.54.0&&< 0.54.10.54.1go get github.com/CosmWasm/wasmd@v0.54.1
🐹Gogithub.com/CosmWasm/wasmd≥ 0.51.0&&< 0.53.30.53.3go get github.com/CosmWasm/wasmd@v0.53.3

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/CosmWasm/wasmd, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/CosmWasm/wasmd to 0.60.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-79xg-q4qm-7v9w is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

# CWA-2025-006: Improper error handling may lead to IBC channel opening despite error **Severity** High (Considerable + Likely)[^1] **Affected versions:** - wasmd 0.60.0 - wasmd >= 0.51.0 < 0.55.1 **Patched versions:** - wasmd 0.60.1, 0.55.1, 0.54.1, 0.53.3 ## Description of the bug A contract erroring during IBC channel opening does not prevent the channel from opening. ## Applying the patch The patch will be shipped in a wasmd release. You will also have to update `libwasmvm` if you build statically. If you already use the latest / close to latest wasmd, you can update more or less
O3 Security · Impact-Aware SCA

Is GHSA-79xg-q4qm-7v9w in your dependencies?

Find it across Go, including transitive dependencies.

CWA-2025-006: wasmd's improper error handling may…