NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
CRITICAL severity

Improper Authentication in BuildbotGHSA-g86p-hgx5-2pfh

CRITICAL

GHSA-g86p-hgx5-2pfh is a critical-severity (CVSS 9.8) Improper Authentication vulnerability in buildbot. A fix is available for buildbot — see the affected versions and patch details below.

Also known asCVE-2019-12300PYSEC-2019-6
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs79th percentile — riskier than 79% of all scored CVEsHighest risk
0.00%0.78%1.56%2.34%0.5%1.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐍buildbot🐍buildbot

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Buildbot before 1.8.2 and 2.x before 2.3.1 accepts a user-submitted authorization token from OAuth and uses it to authenticate a user. If an attacker has a token allowing them to read the user details of a victim, they can login as the victim.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIbuildbotall versions1.8.2pip install --upgrade 'buildbot==1.8.2'
🐍PyPIbuildbot≥ 2.0.0&&< 2.3.12.3.1pip install --upgrade 'buildbot==2.3.1'

Affected Products

1 product · 2 configurations
Application
buildbotbuildbot
≥ 2.0.0 && < 2.3.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for buildbot, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update buildbot to 1.8.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-g86p-hgx5-2pfh is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

Buildbot before 1.8.2 and 2.x before 2.3.1 accepts a user-submitted authorization token from OAuth and uses it to authenticate a user. If an attacker has a token allowing them to read the user details of a victim, they can login as the victim.
O3 Security · Impact-Aware SCA

Is GHSA-g86p-hgx5-2pfh in your dependencies?

Find it across PyPI, including transitive dependencies.

Improper Authentication in Buildbot (Critical 9.8)