NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

silverstripe/framework member disclosure in login formGHSA-g84q-cq55-xwgp

MEDIUMFix: silverstripe/silverstripe-framework@f71efb5

GHSA-g84q-cq55-xwgp is a medium-severity (CVSS 5.3) vulnerability in silverstripe/framework. A fix is available for silverstripe/framework — see the affected versions and patch details below.

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Dec 2, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

2 pkgs affected
🐘silverstripe/framework🐘silverstripe/framework

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

There is a user ID enumeration vulnerability in our brute force error messages.

  • Users that don't exist in will never get a locked out message
  • Users that do exist, will get a locked out message

This means an attacker can infer or confirm user details that exist in the member table.

This issue has been resolved by ensuring that login attempt logging and lockout process works equivalently for non-existent users as it does for existant users.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistsilverstripe/framework≥ 3.4.0-rc1&&< 3.4.63.4.6composer require silverstripe/framework:^3.4.6
🐘Packagistsilverstripe/framework≥ 3.5.0-rc1&&< 3.5.43.5.4composer require silverstripe/framework:^3.5.4

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for silverstripe/framework, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update silverstripe/framework to 3.4.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-g84q-cq55-xwgp is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

There is a user ID enumeration vulnerability in our brute force error messages. - Users that don't exist in will never get a locked out message - Users that do exist, will get a locked out message This means an attacker can infer or confirm user details that exist in the member table. This issue has been resolved by ensuring that login attempt logging and lockout process works equivalently for non-existent users as it does for existant users.
O3 Security · Impact-Aware SCA

Is GHSA-g84q-cq55-xwgp in your dependencies?

Find it across Packagist, including transitive dependencies.

GHSA-g84q-cq55-xwgp: framework — Fixed in 3.4.6