GHSA-g7hw-jh4p-75wr is a medium-severity (CVSS 6.1) vulnerability in typo3/cms. A fix is available for typo3/cms — see the affected versions and patch details below.
Real-World Exposure
typo3/cms🐘typo3/cms🐘typo3/cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
It has been discovered that the output table listing in the “Files” backend module is vulnerable to cross-site scripting when a file extension contains malicious sequences.
Access to the file system of the server - either directly or through synchronization - is required to exploit the vulnerability.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/cms | ≥ 10.0.0&&< 10.2.1 | 10.2.1composer require typo3/cms:^10.2.1 |
| 🐘Packagist | typo3/cms | ≥ 8.0.0&&< 8.7.30 | 8.7.30composer require typo3/cms:^8.7.30 |
| 🐘Packagist | typo3/cms | ≥ 9.0.0&&< 9.5.12 | 9.5.12composer require typo3/cms:^9.5.12 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/cms to 10.2.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-g7hw-jh4p-75wr is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-g7hw-jh4p-75wr in your dependencies?
Find it across Packagist, including transitive dependencies.