TYPO3 Denial of Service in Frontend Record RegistrationGHSA-g585-crjf-vhwq
HIGHFix: TYPO3/typo3@05011d1GHSA-g585-crjf-vhwq is a high-severity (CVSS 7.5) vulnerability in typo3/cms. A fix is available for typo3/cms — see the affected versions and patch details below.
Real-World Exposure
typo3/cms🐘typo3/cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
TYPO3’s built-in record registration functionality (aka basic shopping cart) using recs URL parameters is vulnerable to denial of service. Failing to properly ensure that anonymous user sessions are valid, attackers can use this vulnerability in order to create an arbitrary amount of individual session-data records in the database.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/cms | ≥ 7.0.0&&< 7.6.32 | 7.6.32composer require typo3/cms:^7.6.32 |
| 🐘Packagist | typo3/cms | ≥ 8.0.0&&< 8.7.21 | 8.7.21composer require typo3/cms:^8.7.21 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/cms to 7.6.32 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-g585-crjf-vhwq is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is GHSA-g585-crjf-vhwq in your dependencies?
Find it across Packagist, including transitive dependencies.