NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

Cross-site Scripting in GhostGHSA-fh38-9fgr-454w

MEDIUMFix: TryGhost/Ghost#17190

GHSA-fh38-9fgr-454w is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in ghost. A fix is available for ghost — see the affected versions and patch details below.

Also known asBIT-ghost-2024-23725CVE-2024-23725
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-fh38-9fgr-454w.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs38th percentile — riskier than 38% of all scored CVEsHighest risk
0.00%0.31%0.62%0.94%0.1%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

8other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
ghostnpm
28Kdownloads / week

Description

Ghost before 5.76.0 allows XSS via a post excerpt in excerpt.js. An XSS payload can be rendered in post summaries.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmghostall versions5.76.0npm install ghost@5.76.0

Affected Products

1 product · 1 configurations
Application
ghostghost
< 5.76.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ghost, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ghost to 5.76.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-fh38-9fgr-454w is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Ghost before 5.76.0 allows XSS via a post excerpt in excerpt.js. An XSS payload can be rendered in post summaries.
O3 Security · Impact-Aware SCA

Is GHSA-fh38-9fgr-454w in your dependencies?

Find it across npm, including transitive dependencies.

Cross-site Scripting in Ghost (Medium 6.1)