NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

OpenClaw has Windows Lobster shell fallback command injection in constrained fallback pathGHSA-fg3m-vhrr-8gj6

Fix: openclaw/openclaw@ba7be01

GHSA-fg3m-vhrr-8gj6 is a OS Command Injection vulnerability in openclaw. A fix is available for openclaw — see the affected versions and patch details below.

Also known asCVE-2026-31995
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-fg3m-vhrr-8gj6.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk+0.01%
Lower risk than most CVEs47th percentile — riskier than 47% of all scored CVEsHighest risk
0.00%0.43%0.86%1.30%0.0%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

133other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
openclawnpm
2.5Mdownloads / week

Description

Summary

On Windows, the Lobster extension previously retried certain spawn failures (ENOENT/EINVAL) with shell: true for wrapper compatibility. In that fallback path, tool-provided arguments could be interpreted by cmd.exe if fallback was triggered.

Affected Packages / Versions

  • Package: openclaw (npm)
  • Latest published version at triage: 2026.2.17
  • Affected range: >= 2026.1.21 <= 2026.2.17
  • Patched version: 2026.2.19 (pre-set for next release)

Fix

The Windows shell fallback was removed. Wrapper compatibility is preserved by resolving .cmd/.bat shims to a concrete Node entrypoint (or executable) and executing with explicit argv (no shell). If a safe entrypoint cannot be resolved, execution now fails closed with a guided error.

Fix Commit(s)

  • ba7be018da354ea9f803ed356d20464df0437916

Severity Context

This issue requires Windows plus fallback-triggering conditions, and argument control through a local operator-defined workflow.

OpenClaw thanks @tdjackey for reporting.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmopenclaw≥ 2026.1.21&&< 2026.2.192026.2.19npm install openclaw@2026.2.19

Affected Products

1 product · 1 configurations
Application
openclawopenclaw
≥ 2026.1.21 && < 2026.2.19
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for openclaw, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update openclaw to 2026.2.19 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-fg3m-vhrr-8gj6 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

### Summary On Windows, the Lobster extension previously retried certain spawn failures (`ENOENT`/`EINVAL`) with `shell: true` for wrapper compatibility. In that fallback path, tool-provided arguments could be interpreted by `cmd.exe` if fallback was triggered. ### Affected Packages / Versions - Package: `openclaw` (npm) - Latest published version at triage: `2026.2.17` - Affected range: `>= 2026.1.21 <= 2026.2.17` - Patched version: `2026.2.19` (pre-set for next release) ### Fix The Windows shell fallback was removed. Wrapper compatibility is preserved by resolving `.cmd`/`.bat` shims to a
O3 Security · Impact-Aware SCA

Is GHSA-fg3m-vhrr-8gj6 in your dependencies?

Find it across npm, including transitive dependencies.

OpenClaw has Windows Lobster shell fallback command…