CVE-2026-31995 — openclaw
Fix: openclaw/openclaw@ba7be01CVE-2026-31995 is a OS Command Injection vulnerability in openclaw. A fix is available for openclaw — see the affected versions and patch details below.
OpenClaw 2026.1.21 < 2026.2.19 - Command Injection via Windows Shell Fallback in Lobster Extension
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-31995.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
openclawnpmDescription
Summary
On Windows, the Lobster extension previously retried certain spawn failures (ENOENT/EINVAL) with shell: true for wrapper compatibility. In that fallback path, tool-provided arguments could be interpreted by cmd.exe if fallback was triggered.
Affected Packages / Versions
- Package:
openclaw(npm) - Latest published version at triage:
2026.2.17 - Affected range:
>= 2026.1.21 <= 2026.2.17 - Patched version:
2026.2.19(pre-set for next release)
Fix
The Windows shell fallback was removed. Wrapper compatibility is preserved by resolving .cmd/.bat shims to a concrete Node entrypoint (or executable) and executing with explicit argv (no shell). If a safe entrypoint cannot be resolved, execution now fails closed with a guided error.
Fix Commit(s)
ba7be018da354ea9f803ed356d20464df0437916
Severity Context
This issue requires Windows plus fallback-triggering conditions, and argument control through a local operator-defined workflow.
OpenClaw thanks @tdjackey for reporting.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | openclaw | ≥ 2026.1.21&&< 2026.2.19 | 2026.2.19npm install openclaw@2026.2.19 |
Affected Products
openclawopenclawDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for openclaw, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update openclaw to 2026.2.19 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-31995 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2026-31995 in your dependencies?
Find it across npm, including transitive dependencies.