NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

TensorFlow vulnerable to OOB write in `scatter_nd` in TF LiteGHSA-ffjm-4qwc-7cmf

HIGHFix: tensorflow/tensorflow@b4d4b4c

GHSA-ffjm-4qwc-7cmf is a high-severity (CVSS 7) Out-of-bounds Write vulnerability in tensorflow. A fix is available for tensorflow — see the affected versions and patch details below.

Also known asBIT-tensorflow-2022-35939CVE-2022-35939PYSEC-2026-3171PYSEC-2026-3319PYSEC-2026-989
Published
Updated
Affected
9 pkgs
Patched
9 / 9
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-ffjm-4qwc-7cmf.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs47th percentile — riskier than 47% of all scored CVEsHighest risk
0.00%0.36%0.71%1.07%0.2%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

9 pkgs affected
🐍tensorflow🐍tensorflow🐍tensorflow🐍tensorflow-cpu🐍tensorflow-cpu🐍tensorflow-cpu🐍tensorflow-gpu🐍tensorflow-gpu+1 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Impact

The ScatterNd function takes an input argument that determines the indices of of the output tensor. An input index greater than the output tensor or less than zero will either write content at the wrong index or trigger a crash.

Patches

We have patched the issue in GitHub commit b4d4b4cb019bd7240a52daa4ba61e3cc814f0384.

The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range.

For more information

Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.

Attribution

This vulnerability has been reported by Hui Peng from Baidu Security.

Affected Packages

9 total 9 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPItensorflowall versions2.7.2pip install --upgrade 'tensorflow==2.7.2'
🐍PyPItensorflow≥ 2.8.0&&< 2.8.12.8.1pip install --upgrade 'tensorflow==2.8.1'
🐍PyPItensorflow≥ 2.9.0&&< 2.9.12.9.1pip install --upgrade 'tensorflow==2.9.1'
🐍PyPItensorflow-cpuall versions2.7.2pip install --upgrade 'tensorflow-cpu==2.7.2'
🐍PyPItensorflow-cpu≥ 2.8.0&&< 2.8.12.8.1pip install --upgrade 'tensorflow-cpu==2.8.1'
🐍PyPItensorflow-cpu≥ 2.9.0&&< 2.9.12.9.1pip install --upgrade 'tensorflow-cpu==2.9.1'

Affected Products

1 product · 7 configurations
Application
tensorflowgoogle
≥ 2.9.0 && < 2.9.1
1 version
2.10

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tensorflow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update tensorflow to 2.7.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-ffjm-4qwc-7cmf is resolved across your whole dependency graph.

  3. Workarounds

    Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.

Frequently Asked Questions

### Impact The [`ScatterNd`](https://github.com/tensorflow/tensorflow/blob/266558ac4c1f361e9a178ee9d3f0ce2e648ae499/tensorflow/lite/kernels/internal/reference/reference_ops.h#L659-L698) function takes an input argument that determines the indices of of the output tensor. An input index greater than the output tensor or less than zero will either write content at the wrong index or trigger a crash. ### Patches We have patched the issue in GitHub commit [b4d4b4cb019bd7240a52daa4ba61e3cc814f0384](https://github.com/tensorflow/tensorflow/commit/b4d4b4cb019bd7240a52daa4ba61e3cc814f0384). The fix
O3 Security · Impact-Aware SCA

Is GHSA-ffjm-4qwc-7cmf in your dependencies?

Find it across PyPI, including transitive dependencies.

TensorFlow vulnerable to OOB write in `scatter_nd` in TF…