Improper Neutralization of Input During Web Page Generation in Spring FrameworkGHSA-ff7p-jqjm-v66h
Fix: spring-projects/spring-framework@741b4b2GHSA-ff7p-jqjm-v66h is a Cross-site Scripting (XSS) vulnerability in org.springframework:spring-webmvc. A fix is available for org.springframework:spring-webmvc — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.springframework:spring-webmvc☕org.springframework:spring-webmvcReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Cross-site scripting (XSS) vulnerability in web/servlet/tags/form/FormTag.java in Spring MVC in Spring Framework 3.0.0 before 3.2.8 and 4.0.0 before 4.0.2 allows remote attackers to inject arbitrary web script or HTML via the requested URI in a default action.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.springframework:spring-webmvc | ≥ 3.0.0&&< 3.2.8.RELEASE | 3.2.8.RELEASEorg.springframework:spring-webmvc:3.2.8.RELEASE |
| ☕Maven | org.springframework:spring-webmvc | ≥ 4.0.0&&< 4.0.2.RELEASE | 4.0.2.RELEASEorg.springframework:spring-webmvc:4.0.2.RELEASE |
Affected Products
spring frameworkpivotal_softwareDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.springframework:spring-webmvc, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.springframework:spring-webmvc to 3.2.8.RELEASE or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-ff7p-jqjm-v66h is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
The Red Hat Security Response Team has rated this issue as having Moderate security impact. OpenShift Enterprise 1 is currently in the Production 1 phase of its lifecycle, as such this issue is not currently planned to be addressed in future updates. For additional information, refer to the Satellite Life Cycle:…
Frequently Asked Questions
Is GHSA-ff7p-jqjm-v66h in your dependencies?
Find it across Maven, including transitive dependencies.