NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2014-1904 — spring-webmvc

Fix: spring-projects/spring-framework@741b4b2

CVE-2014-1904 is a Cross-site Scripting (XSS) vulnerability in org.springframework:spring-webmvc. A fix is available for org.springframework:spring-webmvc — see the affected versions and patch details below.

Improper Neutralization of Input During Web Page Generation in Spring Framework

Also known asGHSA-ff7p-jqjm-v66h
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Oct 28, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
6.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs94th percentile — riskier than 94% of all scored CVEsHighest risk
0.28%3.00%5.71%8.42%1.8%6.9%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
☕org.springframework:spring-webmvc☕org.springframework:spring-webmvc

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in web/servlet/tags/form/FormTag.java in Spring MVC in Spring Framework 3.0.0 before 3.2.8 and 4.0.0 before 4.0.2 allows remote attackers to inject arbitrary web script or HTML via the requested URI in a default action.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.springframework:spring-webmvc≥ 3.0.0&&< 3.2.8.RELEASE3.2.8.RELEASEorg.springframework:spring-webmvc:3.2.8.RELEASE
☕Mavenorg.springframework:spring-webmvc≥ 4.0.0&&< 4.0.2.RELEASE4.0.2.RELEASEorg.springframework:spring-webmvc:4.0.2.RELEASE

Affected Products

1 product · 2 configurations
Application
spring frameworkpivotal_software
≥ 4.0.0 && < 4.0.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.springframework:spring-webmvc, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.springframework:spring-webmvc to 3.2.8.RELEASE or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-1904 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

The Red Hat Security Response Team has rated this issue as having Moderate security impact. OpenShift Enterprise 1 is currently in the Production 1 phase of its lifecycle, as such this issue is not currently planned to be addressed in future updates. For additional information, refer to the Satellite Life Cycle:…

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in web/servlet/tags/form/FormTag.java in Spring MVC in Spring Framework 3.0.0 before 3.2.8 and 4.0.0 before 4.0.2 allows remote attackers to inject arbitrary web script or HTML via the requested URI in a default action.
O3 Security · Impact-Aware SCA

Is CVE-2014-1904 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2014-1904: spring-webmvc XSS — Fix Available