TYPO3 Security Misconfiguration in Install Tool CookieGHSA-f777-f784-36gm
HIGHFix: TYPO3/typo3@13328b0GHSA-f777-f784-36gm is a high-severity (CVSS 8.1) vulnerability in typo3/cms. A fix is available for typo3/cms — see the affected versions and patch details below.
Real-World Exposure
typo3/cms🐘typo3/cms🐘typo3/cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
It has been discovered that cookies created in the Install Tool are not hardened to be submitted only via HTTP. In combination with other vulnerabilities such as cross-site scripting it can lead to hijacking an active and valid session in the Install Tool.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/cms | ≥ 7.0.0&&< 7.6.32 | 7.6.32composer require typo3/cms:^7.6.32 |
| 🐘Packagist | typo3/cms | ≥ 8.0.0&&< 8.7.21 | 8.7.21composer require typo3/cms:^8.7.21 |
| 🐘Packagist | typo3/cms | ≥ 9.0.0&&< 9.5.2 | 9.5.2composer require typo3/cms:^9.5.2 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/cms to 7.6.32 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-f777-f784-36gm is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-f777-f784-36gm in your dependencies?
Find it across Packagist, including transitive dependencies.