TYPO3 Information Disclosure of Installed ExtensionsGHSA-f624-8hfq-5fh3
MEDIUMFix: TYPO3/typo3@889ed77GHSA-f624-8hfq-5fh3 is a medium-severity (CVSS 5.3) vulnerability in typo3/cms. A fix is available for typo3/cms — see the affected versions and patch details below.
Real-World Exposure
typo3/cms🐘typo3/cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
It has been discovered that mechanisms used for configuration of RequireJS package loading are susceptible to information disclosure. This way a potential attack can retrieve additional information about installed system and third party extensions.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/cms | ≥ 8.0.0&&< 8.7.23 | 8.7.23composer require typo3/cms:^8.7.23 |
| 🐘Packagist | typo3/cms | ≥ 9.0.0&&< 9.5.4 | 9.5.4composer require typo3/cms:^9.5.4 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/cms to 8.7.23 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-f624-8hfq-5fh3 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Frequently Asked Questions
Is GHSA-f624-8hfq-5fh3 in your dependencies?
Find it across Packagist, including transitive dependencies.