Angular: Template and Attribute Namespace Sanitization Bypass (XSS)GHSA-f3m7-gqxr-g87x
MEDIUMFix: angular/angular#68689GHSA-f3m7-gqxr-g87x is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in @angular/core. A fix is available for @angular/core — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-f3m7-gqxr-g87x.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
@angular/corenpmDescription
An issue in the @angular/compiler and @angular/core packages allows bypassing element and attribute sanitization/validation through specific namespace workarounds.
Specifically, namespaced script elements (e.g., <svg:script> or <:svg:script>) were not properly identified as script elements by the Angular template preparser, allowing them to pass through template compilation without being stripped.
Furthermore, security context schema mappings for element attributes did not consistently handle attributes within namespaced elements (like SVG and MathML), opening up gaps where malicious namespaced attributes could bypass runtime and compile-time sanitizers.
Combined, these flaws enable an attacker who can inject or supply a template/tag structure with custom namespaces to bypass Angular's script-stripping logic and attribute sanitizers, leading to client-side Cross-Site Scripting (XSS).
Impact
Any Angular application that compiles user-controlled templates at runtime, or relies on sanitization of namespaced elements/attributes, is vulnerable to this security bypass.
Once exploited, this allows a malicious actor to inject a namespaced script element or dynamic attribute bindings, bypassing core sanitization constraints to execute arbitrary JavaScript within the target user's browser context. This could lead to session hijacking, sensitive data exposure, or unauthorized actions on behalf of the user.
Attack Preconditions
To successfully exploit these vulnerabilities, the following environment parameters and application states must all concurrently exist:
- User-Controlled Template Input: The application must accept user-controlled inputs that are directly processed by the Angular template compiler at runtime.
- Namespace Parsing Support: The input structure must employ custom namespace prefixes (such as
<svg:script>) to evade standard tag-name blocklists/checks. - Absence of Additional Context Sanitization: The application does not perform separate input sanitization before feeding values to the Angular compiler.
Patches
- 22.0.0-rc.2
- 21.2.15
- 20.3.22
- 19.2.23
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @angular/core | ≥ 21.0.0-next.0&&< 21.2.15 | 21.2.15npm install @angular/core@21.2.15 |
| 📦npm | @angular/core | ≥ 22.0.0-next.0&&< 22.0.0-rc.2 | 22.0.0-rc.2npm install @angular/core@22.0.0-rc.2 |
| 📦npm | @angular/core | ≥ 20.0.0-next.0&&< 20.3.22 | 20.3.22npm install @angular/core@20.3.22 |
| 📦npm | @angular/core | ≥ 19.0.0-next.0&&< 19.2.22 | 19.2.22npm install @angular/core@19.2.22 |
| 📦npm | @angular/core | all versions | No fix |
| 📦npm | @angular/compiler | ≥ 21.0.0-next.0&&< 21.2.15 | 21.2.15npm install @angular/compiler@21.2.15 |
Affected Products
angularangularDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @angular/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update @angular/core to 21.2.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-f3m7-gqxr-g87x is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
A flaw was found in Angular's @angular/compiler and @angular/core packages. Namespaced script elements (e.g., <svg:script>) were not properly identified as script elements by the Angular template preparser, and security context schema mappings did not consistently handle attributes within namespaced elements.…
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for GHSA-f3m7-gqxr-g87x (CC BY 4.0)
Frequently Asked Questions
Is GHSA-f3m7-gqxr-g87x in your dependencies?
Find it across npm, including transitive dependencies.