CVE-2026-27970 — @angular/core
Fix: angular/angular@306f367CVE-2026-27970 is a Cross-site Scripting (XSS) vulnerability in @angular/core. A fix is available for @angular/core — see the affected versions and patch details below.
Angular i18n vulnerable to Cross-Site Scripting (XSS)
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-27970.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
@angular/corenpmDescription
A Cross-site Scripting (XSS) vulnerability has been identified in the Angular internationalization (i18n) pipeline. In ICU messages (International Components for Unicode), HTML from translated content was not properly sanitized and could execute arbitrary JavaScript.
Angular i18n typically involves three steps, extracting all messages from an application in the source language, sending the messages to be translated, and then merging their translations back into the final source code. Translations are frequently handled by contracts with specific partner companies, and involve sending the source messages to a separate contractor before receiving final translations for display to the end user.
If the returned translations have malicious content, it could be rendered into the application and execute arbitrary JavaScript.
Impact
When successfully exploited, this vulnerability allows for execution of attacker controlled JavaScript in the application origin. Depending on the nature of the application being exploited this could lead to:
- Credential Exfiltration: Stealing sensitive user data stored in page memory, LocalStorage, IndexedDB, or cookies available to JS and sending them to an attacker controlled server.
- Page Vandalism: Mutating the page to read or act differently than intended by the developer.
Attach Preconditions
- The attacker must compromise the translation file (xliff, xtb, etc.).
- Unlike most XSS vulnerabilities, this one is not exploitable by arbitrary users. An attacker must first compromise an application's translation file before they can escalate privileges into the Angular application client.
- The victim application must use Angular i18n.
- The victim application must use one or more ICU messages.
- The victim application must render an ICU message.
- The victim application must not defend against XSS via a safe Content-Security Policy (CSP) or Trusted Types.
Patches
- 21.2.0
- 21.1.6
- 20.3.17
- 19.2.19
Workarounds
Until the patch is applied, developers should consider:
- Reviewing and verifying translated content received from untrusted third parties before incorporating it in an Angular application.
- Enabling strict CSP controls to block unauthorized JavaScript from executing on the page.
- Enabling Trusted Types to enforce proper HTML sanitization.
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @angular/core | ≥ 21.2.0-next.0&&< 21.2.0 | 21.2.0npm install @angular/core@21.2.0 |
| 📦npm | @angular/core | ≥ 21.0.0-next.0&&< 21.1.6 | 21.1.6npm install @angular/core@21.1.6 |
| 📦npm | @angular/core | ≥ 20.0.0-next.0&&< 20.3.17 | 20.3.17npm install @angular/core@20.3.17 |
| 📦npm | @angular/core | ≥ 19.0.0-next.0&&< 19.2.19 | 19.2.19npm install @angular/core@19.2.19 |
| 📦npm | @angular/core | all versions | No fix |
Affected Products
angularangularDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @angular/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update @angular/core to 21.2.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-27970 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2026-27970 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Ceph Storage 9.2 | rhceph/rhceph-9-rhel10:1790843527 | RHSA-2026:86618 |
Frequently Asked Questions
Is CVE-2026-27970 in your dependencies?
Find it across npm, including transitive dependencies.