NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

Regular expression denial of service in Apache ShenYuGHSA-cw56-j3fm-7w57

HIGH

GHSA-cw56-j3fm-7w57 is a high-severity (CVSS 7.5) CWE-1333 vulnerability in org.apache.shenyu:shenyu. A fix is available for org.apache.shenyu:shenyu — see the affected versions and patch details below.

Also known asCVE-2022-26650
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs86th percentile — riskier than 86% of all scored CVEsHighest risk
0.59%1.44%2.30%3.16%1.1%2.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.apache.shenyu:shenyu☕org.apache.shenyu:shenyu-bootstrap

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

In Apache ShenYui, ShenYu-Bootstrap, RegexPredicateJudge.java uses Pattern.matches(conditionData.getParamValue(), realData) to make judgments, where both parameters are controllable by the user. This can cause an attacker pass in malicious regular expressions and characters causing a resource exhaustion. This issue affects Apache ShenYu (incubating) 2.4.0, 2.4.1 and 2.4.2 and is fixed in 2.4.3.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.shenyu:shenyu≥ 2.4.0&&< 2.4.32.4.3org.apache.shenyu:shenyu:2.4.3
☕Mavenorg.apache.shenyu:shenyu-bootstrap≥ 2.4.0&&< 2.4.32.4.3org.apache.shenyu:shenyu-bootstrap:2.4.3

Affected Products

1 product · 3 configurations
Application
shenyuapache
3 versions
2.4.02.4.12.4.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.shenyu:shenyu, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.shenyu:shenyu to 2.4.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-cw56-j3fm-7w57 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

In Apache ShenYui, ShenYu-Bootstrap, RegexPredicateJudge.java uses Pattern.matches(conditionData.getParamValue(), realData) to make judgments, where both parameters are controllable by the user. This can cause an attacker pass in malicious regular expressions and characters causing a resource exhaustion. This issue affects Apache ShenYu (incubating) 2.4.0, 2.4.1 and 2.4.2 and is fixed in 2.4.3.
O3 Security · Impact-Aware SCA

Is GHSA-cw56-j3fm-7w57 in your dependencies?

Find it across Maven, including transitive dependencies.

Regular expression denial of service in Apache ShenYu