CVE-2022-26650 — shenyu
HIGHCVE-2022-26650 is a high-severity (CVSS 7.5) CWE-1333 vulnerability in org.apache.shenyu:shenyu. A fix is available for org.apache.shenyu:shenyu — see the affected versions and patch details below.
Apache ShenYu (incubating) Regular expression denial of service
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.shenyu:shenyu☕org.apache.shenyu:shenyu-bootstrapReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
In Apache ShenYui, ShenYu-Bootstrap, RegexPredicateJudge.java uses Pattern.matches(conditionData.getParamValue(), realData) to make judgments, where both parameters are controllable by the user. This can cause an attacker pass in malicious regular expressions and characters causing a resource exhaustion. This issue affects Apache ShenYu (incubating) 2.4.0, 2.4.1 and 2.4.2 and is fixed in 2.4.3.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.shenyu:shenyu | ≥ 2.4.0&&< 2.4.3 | 2.4.3org.apache.shenyu:shenyu:2.4.3 |
| ☕Maven | org.apache.shenyu:shenyu-bootstrap | ≥ 2.4.0&&< 2.4.3 | 2.4.3org.apache.shenyu:shenyu-bootstrap:2.4.3 |
Affected Products
shenyuapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.shenyu:shenyu, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.shenyu:shenyu to 2.4.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-26650 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2022-26650 in your dependencies?
Find it across Maven, including transitive dependencies.