NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

Froxlor vulnerable to Command InjectionGHSA-cp68-42pf-6627

HIGHFix: froxlor/froxlor@090cfc2

GHSA-cp68-42pf-6627 is a high-severity (CVSS 8.8) CWE-77 vulnerability in froxlor/froxlor. 5 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for froxlor/froxlor — see the affected versions and patch details below.

Also known asCVE-2023-0315
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
5 known
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for GHSA-cp68-42pf-6627.

EPSS Exploitation Probability

via FIRST.org ↗
97.7%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
86.6%91.0%95.5%100.0%89.1%97.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘froxlor/froxlor

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Command Injection in GitHub repository froxlor/froxlor prior to 2.0.8.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistfroxlor/froxlorall versions2.0.8composer require froxlor/froxlor:^2.0.8

Affected Products

1 product · 1 configurations
Application
froxlorfroxlor
< 2.0.8
range
Exploits & PoCs
5

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-51263webappsphp

Froxlor 2.0.3 Stable - Remote Code Execution (RCE)

by Askar · Apr 5, 2023

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for froxlor/froxlor, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update froxlor/froxlor to 2.0.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-cp68-42pf-6627 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

Command Injection in GitHub repository froxlor/froxlor prior to 2.0.8.
O3 Security · Impact-Aware SCA

Is GHSA-cp68-42pf-6627 in your dependencies?

Find it across Packagist, including transitive dependencies.

Froxlor vulnerable to Command Injection (High 8.8)