NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

Parse Server affected by denial-of-service via unbounded query complexity in REST and GraphQL APIGHSA-cmj3-wx7h-ffvg

GHSA-cmj3-wx7h-ffvg is a CWE-770 vulnerability in parse-server. A fix is available for parse-server — see the affected versions and patch details below.

Also known asBIT-parse-2026-30946CVE-2026-30946
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-cmj3-wx7h-ffvg.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs48th percentile — riskier than 48% of all scored CVEsHighest risk
0.00%0.38%0.76%1.14%0.0%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

62other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
parse-servernpm
74Kdownloads / week

Description

Impact

An unauthenticated attacker can exhaust Parse Server resources (CPU, memory, database connections) through crafted queries that exploit the lack of complexity limits in the REST and GraphQL APIs.

All Parse Server deployments using the REST or GraphQL API are affected.

Patches

The vulnerability is fixed by introducing configurable request complexity limits via the requestComplexity server option with the following keys:

  • subqueryDepth: Maximum nesting depth for $inQuery, $notInQuery, $select, $dontSelect
  • includeDepth: Maximum depth of dot-separated include paths
  • includeCount: Maximum number of include fields per query
  • graphQLDepth: Maximum depth of GraphQL field selections
  • graphQLFields: Maximum number of field selections in a GraphQL query

Requests using master key or maintenance key bypass these limits. Set any property to -1 to disable that specific limit.

In versions 8.6.15 and 9.5.2-alpha.2, these limits were enabled by default. This unintentionally introduced a breaking change for some applications with legitimate complex queries. In versions 8.6.46 and 9.6.0-alpha.22, the defaults were changed to -1 (disabled) to restore backwards compatibility.

The limits remain available as configuration options. To mitigate the vulnerability, upgrade to a patched version and set each requestComplexity property to a value appropriate for your application.

Workarounds

There is no known workaround.

References

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
📦npmparse-serverall versions8.6.15npm install parse-server@8.6.15
📦npmparse-server≥ 9.0.0&&< 9.5.2-alpha.29.5.2-alpha.2npm install parse-server@9.5.2-alpha.2

Affected Products

1 product · 3 configurations
Application
parse-serverparseplatform
≥ 9.0.0 && < 9.5.2
1 version
9.5.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for parse-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update parse-server to 8.6.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-cmj3-wx7h-ffvg is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

### Impact An unauthenticated attacker can exhaust Parse Server resources (CPU, memory, database connections) through crafted queries that exploit the lack of complexity limits in the REST and GraphQL APIs. All Parse Server deployments using the REST or GraphQL API are affected. ### Patches The vulnerability is fixed by introducing configurable request complexity limits via the `requestComplexity` server option with the following keys: - `subqueryDepth`: Maximum nesting depth for `$inQuery`, `$notInQuery`, `$select`, `$dontSelect` - `includeDepth`: Maximum depth of dot-separated `include`
O3 Security · Impact-Aware SCA

Is GHSA-cmj3-wx7h-ffvg in your dependencies?

Find it across npm, including transitive dependencies.

Parse Server affected by denial-of-service via unbounded…