CVE-2026-30946 — parse-server
CVE-2026-30946 is a CWE-770 vulnerability in parse-server. A fix is available for parse-server — see the affected versions and patch details below.
Parse Server affected by denial-of-service via unbounded query complexity in REST and GraphQL API
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-30946.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
parse-servernpmDescription
Impact
An unauthenticated attacker can exhaust Parse Server resources (CPU, memory, database connections) through crafted queries that exploit the lack of complexity limits in the REST and GraphQL APIs.
All Parse Server deployments using the REST or GraphQL API are affected.
Patches
The vulnerability is fixed by introducing configurable request complexity limits via the requestComplexity server option with the following keys:
subqueryDepth: Maximum nesting depth for$inQuery,$notInQuery,$select,$dontSelectincludeDepth: Maximum depth of dot-separatedincludepathsincludeCount: Maximum number ofincludefields per querygraphQLDepth: Maximum depth of GraphQL field selectionsgraphQLFields: Maximum number of field selections in a GraphQL query
Requests using master key or maintenance key bypass these limits. Set any property to -1 to disable that specific limit.
In versions 8.6.15 and 9.5.2-alpha.2, these limits were enabled by default. This unintentionally introduced a breaking change for some applications with legitimate complex queries. In versions 8.6.46 and 9.6.0-alpha.22, the defaults were changed to -1 (disabled) to restore backwards compatibility.
The limits remain available as configuration options. To mitigate the vulnerability, upgrade to a patched version and set each requestComplexity property to a value appropriate for your application.
Workarounds
There is no known workaround.
References
- GitHub security advisory: https://github.com/parse-community/parse-server/security/advisories/GHSA-cmj3-wx7h-ffvg
- Fix Parse Server 9: https://github.com/parse-community/parse-server/releases/tag/9.5.2-alpha.2
- Fix Parse Server 8: https://github.com/parse-community/parse-server/releases/tag/8.6.15
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | parse-server | all versions | 8.6.15npm install parse-server@8.6.15 |
| 📦npm | parse-server | ≥ 9.0.0&&< 9.5.2-alpha.2 | 9.5.2-alpha.2npm install parse-server@9.5.2-alpha.2 |
Affected Products
parse-serverparseplatformDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for parse-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update parse-server to 8.6.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-30946 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2026-30946 in your dependencies?
Find it across npm, including transitive dependencies.