NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

snapd Race Condition vulnerabilityGHSA-cjqf-877p-7m3f

HIGHFix: snapcore/snapd#12380

GHSA-cjqf-877p-7m3f is a high-severity (CVSS 7.8) CWE-362 vulnerability in github.com/snapcore/snapd. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for github.com/snapcore/snapd — see the affected versions and patch details below.

Also known asCVE-2022-3328GO-2024-2468
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-cjqf-877p-7m3f.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs33th percentile — riskier than 33% of all scored CVEsHighest risk
0.00%0.29%0.59%0.88%0.1%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/snapcore/snapd

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Race condition in snap-confine's must_mkdir_and_open_with_perms()

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/snapcore/snapdall versions2.57.6go get github.com/snapcore/snapd@v2.57.6

Affected Products

2 products · 6 configurations
Application
snapdcanonical
< 2.61.1
range
OS
ubuntu linuxcanonical
5 versions
16.0418.0420.0422.0422.10
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/snapcore/snapd, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/snapcore/snapd to 2.57.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-cjqf-877p-7m3f is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Race condition in snap-confine's `must_mkdir_and_open_with_perms()`
O3 Security · Impact-Aware SCA

Is GHSA-cjqf-877p-7m3f in your dependencies?

Find it across Go, including transitive dependencies.

snapd Race Condition vulnerability (High 7.8)