NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
Not in CISA KEV

PKCS7_verify Certificate Chain Validation Bypass in AWS-LCGHSA-cfwj-9wp5-wqvp

GHSA-cfwj-9wp5-wqvp is a CWE-295 vulnerability. A fix is available — see the affected versions and patch details below.

Also known asGHSA-vw5v-4f2q-w9xfRUSTSEC-2026-0046
Published
Updated
Affected
2 products
Patched
See advisory
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-cfwj-9wp5-wqvp.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs55th percentile — riskier than 55% of all scored CVEsHighest risk
0.00%0.42%0.85%1.27%0.0%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Description

Improper certificate validation in PKCS7_verify() in AWS-LC allows an unauthenticated user to bypass certificate chain verification when processing PKCS7 objects with multiple signers, except the final signer.

Customers of AWS services do not need to take action. Applications using AWS-LC should upgrade to AWS-LC version 1.69.0.

Affected Products

2 products · 2 configurations
Application
aws libcryptoamazon
≥ 1.41.0 && < 1.69.0
range
Application
aws-lc-sysamazon
≥ 0.24.0 && < 0.38.0
range

Detection & mitigation playbook

Vulnerability
  1. Detect

    Identify every host running the affected component and compare the installed build against the fixed version below — for source-built or distro-packaged software the version string, not a lockfile, is the source of truth (`dpkg -l`, `rpm -q`, or the binary's own `--version`).

  2. Fix

    Upgrade the affected component to the fixed release for GHSA-cfwj-9wp5-wqvp, or apply your distribution's backported patch — distro builds are often patched at an older version number, so check your vendor's advisory rather than the upstream version alone.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.
Source: Red Hat security advisory for GHSA-cfwj-9wp5-wqvp (CC BY 4.0)
ProductFixed inAdvisory
Red Hat Trusted Artifact Signer 1.3rhtas/tuffer-rhel9:1773307309RHSA-2026:5459

Frequently Asked Questions

Improper certificate validation in PKCS7_verify() in AWS-LC allows an unauthenticated user to bypass certificate chain verification when processing PKCS7 objects with multiple signers, except the final signer. Customers of AWS services do not need to take action. Applications using AWS-LC should upgrade to AWS-LC version 1.69.0.
O3 Security · Impact-Aware SCA

Is GHSA-cfwj-9wp5-wqvp in your dependencies?

Find it across your dependency tree, including transitive dependencies.

PKCS7_verify Certificate Chain Validation Bypass in…