Fix for arbitrary command execution in custom layout update through blocksGHSA-c9q3-r4rv-mjm7
HIGHFix: OpenMage/magento-lts@289bd4bGHSA-c9q3-r4rv-mjm7 is a high-severity (CVSS 7.2) CWE-77 vulnerability in openmage/magento-lts. A fix is available for openmage/magento-lts — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-c9q3-r4rv-mjm7.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
openmage/magento-lts🐘openmage/magento-ltsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
OpenMage LTS is an e-commerce platform. Prior to versions 19.4.22 and 20.0.19, Custom Layout enabled admin users to execute arbitrary commands via block methods. Versions 19.4.22 and 20.0.19 contain patches for this issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | openmage/magento-lts | all versions | 19.4.22composer require openmage/magento-lts:^19.4.22 |
| 🐘Packagist | openmage/magento-lts | ≥ 20.0.0&&< 20.0.19 | 20.0.19composer require openmage/magento-lts:^20.0.19 |
Affected Products
magentoopenmageDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for openmage/magento-lts, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update openmage/magento-lts to 19.4.22 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-c9q3-r4rv-mjm7 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is GHSA-c9q3-r4rv-mjm7 in your dependencies?
Find it across Packagist, including transitive dependencies.