Insecure Unserialize in TYPO3 BackendGHSA-c7rj-92xr-wprg
MEDIUMGHSA-c7rj-92xr-wprg is a medium-severity (CVSS 5) vulnerability in typo3/cms. A fix is available for typo3/cms — see the affected versions and patch details below.
Real-World Exposure
typo3/cms🐘typo3/cms🐘typo3/cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Failing to properly validate incoming data, the suggest wizard is susceptible to insecure unserialize. To exploit this vulnerability a valid backend user account is needed.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/cms | ≥ 6.2.0&&< 6.2.29 | 6.2.29composer require typo3/cms:^6.2.29 |
| 🐘Packagist | typo3/cms | ≥ 7.6.0&&< 7.6.13 | 7.6.13composer require typo3/cms:^7.6.13 |
| 🐘Packagist | typo3/cms | ≥ 8.0.0&&< 8.4.1 | 8.4.1composer require typo3/cms:^8.4.1 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/cms to 6.2.29 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-c7rj-92xr-wprg is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-c7rj-92xr-wprg in your dependencies?
Find it across Packagist, including transitive dependencies.