NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

Session Fixation in Apache ZeppelinGHSA-c538-924g-99q4

HIGH

GHSA-c538-924g-99q4 is a high-severity (CVSS 8.1) CWE-384 vulnerability in org.apache.zeppelin:zeppelin. A fix is available for org.apache.zeppelin:zeppelin — see the affected versions and patch details below.

Also known asCVE-2017-12619
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs92th percentile — riskier than 92% of all scored CVEsHighest risk
0.00%2.06%4.12%6.19%0.9%4.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.zeppelin:zeppelin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Apache Zeppelin prior to 0.7.3 was vulnerable to session fixation which allowed an attacker to hijack a valid user session. Issue was reported by "stone lone".

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.zeppelin:zeppelinall versions0.7.3org.apache.zeppelin:zeppelin:0.7.3

Affected Products

1 product · 1 configurations
Application
zeppelinapache
< 0.7.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.zeppelin:zeppelin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.zeppelin:zeppelin to 0.7.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-c538-924g-99q4 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

Apache Zeppelin prior to 0.7.3 was vulnerable to session fixation which allowed an attacker to hijack a valid user session. Issue was reported by "stone lone".
O3 Security · Impact-Aware SCA

Is GHSA-c538-924g-99q4 in your dependencies?

Find it across Maven, including transitive dependencies.

Session Fixation in Apache Zeppelin (High 8.1)