silverstripe/framework has Cross-site Scripting vulnerability in page history comparisonGHSA-c4c3-j73v-634r
Fix: silverstripe/silverstripe-framework@2b72c0fGHSA-c4c3-j73v-634r is a security vulnerability in silverstripe/framework. A fix is available for silverstripe/framework — see the affected versions and patch details below.
Real-World Exposure
silverstripe/framework🐘silverstripe/frameworkReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Authenticated user with page edit permission can craft HTML, which when rendered in a page history comparison can execute client scripts.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | silverstripe/framework | ≥ 3.4.0-rc1&&< 3.4.6 | 3.4.6composer require silverstripe/framework:^3.4.6 |
| 🐘Packagist | silverstripe/framework | ≥ 3.5.0-rc1&&< 3.5.4 | 3.5.4composer require silverstripe/framework:^3.5.4 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for silverstripe/framework, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update silverstripe/framework to 3.4.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-c4c3-j73v-634r is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-c4c3-j73v-634r in your dependencies?
Find it across Packagist, including transitive dependencies.