NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

Firefly III vulnerable to stored XSSGHSA-9xmx-rj7j-fv9q

MEDIUMFix: firefly-iii/firefly-iii@def3070

GHSA-9xmx-rj7j-fv9q is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in grumpydictator/firefly-iii. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for grumpydictator/firefly-iii — see the affected versions and patch details below.

Also known asCVE-2019-13644
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for GHSA-9xmx-rj7j-fv9q.

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs55th percentile — riskier than 55% of all scored CVEsHighest risk
0.00%0.42%0.84%1.26%0.2%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘grumpydictator/firefly-iii

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Firefly III before 4.7.17.1 is vulnerable to stored XSS due to lack of filtration of user-supplied data in a budget name. The JavaScript code is contained in a transaction, and is executed on the tags/show/$tag_number$ tag summary page. NOTE: It is asserted that an attacker must have the same access rights as the user in order to be able to execute the vulnerability

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistgrumpydictator/firefly-iiiall versions4.7.17.1composer require grumpydictator/firefly-iii:^4.7.17.1

Affected Products

1 product · 1 configurations
Application
firefly iiifirefly-iii
< 4.7.17.1
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for grumpydictator/firefly-iii, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update grumpydictator/firefly-iii to 4.7.17.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-9xmx-rj7j-fv9q is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Firefly III before 4.7.17.1 is vulnerable to stored XSS due to lack of filtration of user-supplied data in a budget name. The JavaScript code is contained in a transaction, and is executed on the tags/show/$tag_number$ tag summary page. NOTE: It is asserted that an attacker must have the same access rights as the user in order to be able to execute the vulnerability
O3 Security · Impact-Aware SCA

Is GHSA-9xmx-rj7j-fv9q in your dependencies?

Find it across Packagist, including transitive dependencies.

Firefly III vulnerable to stored XSS (Medium 5.4)