NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
.NET
.NET NuGet
Not in CISA KEV
MEDIUM severity

DNN vulnerable to Relative Path TraversalGHSA-9w72-2f23-57gm

MEDIUMFix: dnnsoftware/Dnn.Platform@3697c53

GHSA-9w72-2f23-57gm is a medium-severity (CVSS 4.9) CWE-23 vulnerability in DotNetNuke.Core. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for DotNetNuke.Core — see the affected versions and patch details below.

Also known asCVE-2022-2922
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for GHSA-9w72-2f23-57gm.

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs70th percentile — riskier than 70% of all scored CVEsHighest risk
0.00%0.60%1.19%1.79%0.5%1.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
.NETDotNetNuke.Core.NETDotNetNuke.Web

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.

Description

DNN (GitHub repository dnnsoftware/dnn.platform) prior to 9.11.0 is vulnerable to Relative Path Traversal. Version 9.11.0 contains a patch for this issue.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
.NETNuGetDotNetNuke.Coreall versions9.11.0dotnet add package DotNetNuke.Core --version 9.11.0
.NETNuGetDotNetNuke.Weball versions9.11.0dotnet add package DotNetNuke.Web --version 9.11.0

Affected Products

1 product · 1 configurations
Application
dotnetnukednnsoftware
< 9.11.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for DotNetNuke.Core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update DotNetNuke.Core to 9.11.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-9w72-2f23-57gm is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

DNN (GitHub repository dnnsoftware/dnn.platform) prior to 9.11.0 is vulnerable to Relative Path Traversal. Version 9.11.0 contains a patch for this issue.
O3 Security · Impact-Aware SCA

Is GHSA-9w72-2f23-57gm in your dependencies?

Find it across NuGet, including transitive dependencies.

DNN vulnerable to Relative Path Traversal (Medium 4.9)