NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
.NET
.NET NuGet
Not in CISA KEV
HIGH severity

CVE-2026-24836 — DotNetNuke.Core

HIGH

CVE-2026-24836 is a high-severity (CVSS 7.6) Cross-site Scripting (XSS) vulnerability in DotNetNuke.Core. A fix is available for DotNetNuke.Core — see the affected versions and patch details below.

DotNetNuke.Core Vulnerable to Stored XSS in Scheduler LogNotes

Also known asGHSA-2g5g-hcgh-q3rp
Published
Updated
Affected
2 pkgs
Patched
1 / 2
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-24836.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs17th percentile — riskier than 17% of all scored CVEsHighest risk
0.00%0.25%0.51%0.76%0.0%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
.NETDotNetNuke.Core.NETDotNetNuke.Core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.

Description

DNN (formerly DotNetNuke) is an open-source web content management platform (CMS) in the Microsoft ecosystem. Starting in version 9.0.0 and prior to versions 9.13.10 and 10.2.0, extensions could write richtext in log notes which can include scripts that would run in the PersonaBar when displayed. Versions 9.13.10 and 10.2.0 contain a fix for the issue.

Affected Packages

2 total 1 fixed
EcosystemPackageVulnerable rangeFix
.NETNuGetDotNetNuke.Core≥ 9.0.0No fix
.NETNuGetDotNetNuke.Core≥ 10.0.0&&< 10.02.010.02.0dotnet add package DotNetNuke.Core --version 10.02.0

Affected Products

1 product · 2 configurations
Application
dotnetnukednnsoftware
≥ 10.0.0 && < 10.2.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for DotNetNuke.Core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    A fix is available for CVE-2026-24836; check the affected-versions list above or the advisory for the patched release of DotNetNuke.Core, then make sure no transitive dependency still pins the vulnerable range.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

DNN (formerly DotNetNuke) is an open-source web content management platform (CMS) in the Microsoft ecosystem. Starting in version 9.0.0 and prior to versions 9.13.10 and 10.2.0, extensions could write richtext in log notes which can include scripts that would run in the PersonaBar when displayed. Versions 9.13.10 and 10.2.0 contain a fix for the issue.
O3 Security · Impact-Aware SCA

Is CVE-2026-24836 in your dependencies?

Find it across NuGet, including transitive dependencies.

CVE-2026-24836: DotNetNuke.Core — Fixed in 10.02.0