Cockpit CMS vulnerable to incorrect access controlGHSA-9r25-4j77-9wc7
HIGHGHSA-9r25-4j77-9wc7 is a high-severity (CVSS 7.5) vulnerability in cockpit-hq/cockpit. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for cockpit-hq/cockpit — see the affected versions and patch details below.
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
Exploitation and automatability from CISA’s SSVC triage for GHSA-9r25-4j77-9wc7.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
cockpit-hq/cockpitReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Incorrect access control in the component /models/Content of Cockpit CMS v2.5.2 allows unauthorized attackers to access sensitive data.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | cockpit-hq/cockpit | all versions | 2.6.0composer require cockpit-hq/cockpit:^2.6.0 |
Affected Products
cockpitagentejoResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cockpit-hq/cockpit, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update cockpit-hq/cockpit to 2.6.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-9r25-4j77-9wc7 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is GHSA-9r25-4j77-9wc7 in your dependencies?
Find it across Packagist, including transitive dependencies.