NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

2FA bypass through deleting devices in wagtail-2faGHSA-9gjv-6qq6-v7qm

HIGHFix: labd/wagtail-2fa@ac23550

GHSA-9gjv-6qq6-v7qm is a high-severity (CVSS 7.6) CWE-285 vulnerability in wagtail-2fa. A fix is available for wagtail-2fa — see the affected versions and patch details below.

Also known asCVE-2020-5240PYSEC-2020-219
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs63th percentile — riskier than 63% of all scored CVEsHighest risk
0.00%0.50%1.00%1.50%0.2%1.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍wagtail-2fa

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Impact

Any user with access to the CMS can view and delete other users' 2FA devices by going to the correct path. The user does not require special permissions in order to do so. By deleting the other user's device they can disable the target user's 2FA devices and potentially compromise the account if they figure out their password.

Patches

The problem has been patched in version 1.4.1.

Workarounds

There is no workaround for this issue.

For more information

If you have any questions or comments about this advisory:

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIwagtail-2faall versions1.4.1pip install --upgrade 'wagtail-2fa==1.4.1'

Affected Products

1 product · 1 configurations
Application
wagtail-2falabdigital
< 1.4.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for wagtail-2fa, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update wagtail-2fa to 1.4.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-9gjv-6qq6-v7qm is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

### Impact Any user with access to the CMS can view and delete other users&#39; 2FA devices by going to the correct path. The user does not require special permissions in order to do so. By deleting the other user&#39;s device they can disable the target user&#39;s 2FA devices and potentially compromise the account if they figure out their password. ### Patches The problem has been patched in version 1.4.1. ### Workarounds There is no workaround for this issue. ### For more information If you have any questions or comments about this advisory: * Open an issue in [github.com/labd/wagtail-2fa
O3 Security · Impact-Aware SCA

Is GHSA-9gjv-6qq6-v7qm in your dependencies?

Find it across PyPI, including transitive dependencies.

2FA bypass through deleting devices in wagtail-2fa