NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2019-16766 — wagtail-2fa

HIGHFix: labd/wagtail-2fa@13b1299

CVE-2019-16766 is a high-severity (CVSS 8.8) CWE-290 vulnerability in wagtail-2fa. A fix is available for wagtail-2fa — see the affected versions and patch details below.

2FA bypass in Wagtail through new device path

Also known asGHSA-89px-ww3j-g2mmPYSEC-2019-135
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs74th percentile — riskier than 74% of all scored CVEsHighest risk
0.00%0.65%1.31%1.96%0.2%1.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍wagtail-2fa

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

2FA bypass through new device path

Impact

If someone gains access to someone's Wagtail login credentials, they can log into the CMS and bypass the 2FA check by changing the URL. They can then add a new device and gain full access to the CMS.

Patches

This problem has been patched in version 1.3.0.

Workarounds

There is no workaround at the moment.

For more information

If you have any questions or comments about this advisory:

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIwagtail-2faall versions1.3.0pip install --upgrade 'wagtail-2fa==1.3.0'

Affected Products

1 product · 1 configurations
Application
wagtail-2falabdigital
< 1.3.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for wagtail-2fa, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update wagtail-2fa to 1.3.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-16766 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

## 2FA bypass through new device path ### Impact If someone gains access to someone's Wagtail login credentials, they can log into the CMS and bypass the 2FA check by changing the URL. They can then add a new device and gain full access to the CMS. ### Patches This problem has been patched in version 1.3.0. ### Workarounds There is no workaround at the moment. ### For more information If you have any questions or comments about this advisory: * Open an issue in [github.com/labd/wagtail-2fa](https://github.com/labd/wagtail-2fa) * Email us at [[email protected]](mailto:security@labdigit
O3 Security · Impact-Aware SCA

Is CVE-2019-16766 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2019-16766: wagtail-2fa — Fixed in 1.3.0