laravel-auth0 SDK Vulnerable to Brute Force Authentication Tags of CookieStore SessionsGHSA-9fwj-9mjf-rhj3
CRITICALFix: auth0/laravel-auth0@be2c59aGHSA-9fwj-9mjf-rhj3 is a critical-severity (CVSS 9.1) vulnerability in auth0/login. A fix is available for auth0/login — see the affected versions and patch details below.
Real-World Exposure
auth0/loginReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Overview Session cookies of applications using the laravel-auth0 SDK configured with CookieStore have authentication tags that can be brute forced, which may result in unauthorized access.
Am I Affected? You are affected by this vulnerability if you meet the following pre-conditions:
- Applications using laravel-auth0 SDK with version <=7.16.0
- laravel-auth0 SDK uses the Auth0-PHP SDK with version 8.0.0-BETA1 or higher and below 8.14.0.
- Session storage configured with CookieStore.
Fix Upgrade Auth0/laravel-auth0 to v7.17.0. As an additional precautionary measure, we recommend rotating your cookie encryption keys. Note that once updated, any previous session cookies will be rejected.
Acknowledgement Okta would like to thank Félix Charette for discovering this vulnerability.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | auth0/login | all versions | 7.17.0composer require auth0/login:^7.17.0 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for auth0/login, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update auth0/login to 7.17.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-9fwj-9mjf-rhj3 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-9fwj-9mjf-rhj3 in your dependencies?
Find it across Packagist, including transitive dependencies.