Auth0 Laravel SDK has Improper Audience Validation via Auth0-PHP SDK dependencyGHSA-7hh9-gp72-wh7h
MEDIUMFix: auth0/laravel-auth0@a1c3344GHSA-7hh9-gp72-wh7h is a medium-severity (CVSS 6.8) vulnerability in auth0/login. A fix is available for auth0/login — see the affected versions and patch details below.
Real-World Exposure
auth0/loginReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Description
In applications built with the Auth0-PHP SDK, the audience validation in access tokens is performed improperly. Without proper validation, affected applications may accept ID tokens as Access tokens.
Affected product and versions
Users are affected if they meet the following preconditions:
- Applications using the Auth0 laravel-auth0 SDK with versions between 7.0.0 and 7.19.0,
- Auth0 laravel-auth0 SDK uses the Auth0-PHP SDK with versions between 8.0.0 and 8.17.0.
Resolution
Upgrade Auth0/laravel-auth0 to version 7.20.0 or greater.
Acknowledgement
Okta would like to thank Jafar Sadiq (iaf4r) for their discovery and responsible disclosure.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | auth0/login | ≥ 7.0.0&&< 7.20.0 | 7.20.0composer require auth0/login:^7.20.0 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for auth0/login, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update auth0/login to 7.20.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-7hh9-gp72-wh7h is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-7hh9-gp72-wh7h in your dependencies?
Find it across Packagist, including transitive dependencies.